Wiki PIREH

Des ressources pour utiliser le numérique en histoire

Outils pour utilisateurs

Outils du site


illustrer_son_dossier_de_base_de_donnees

Illustrer son dossier de base de données

Le dictionnaire des données

Le dictionnaire des données d'une table apparaît dans LibreOffice lorsqu'on ouvre cette table en mode édition (clic-droit sur son nom et menu “Editer”). Il est cependant nécessaire de la refaire au propre dans votre dossier, en indiquant le type de données de chaque champ, en en décrivant bien la fonction, et en précisant si il s'agit d'une clé primaire, si la saisie est obligatoire, etc.

Le schéma relationnel des tables

Dans LibreOffice Calc, le menu “Outils” > “Relations” permet d'afficher le schéma des relations entre tables. Vous pouvez en faire une capture d'écran pour illustrer l'articulation des tables dans votre base. Au préalable, assurez-vous que les relations entre tables ont bien été indiquées, que leurs dimensions permettent bien de voir leurs champs, et qu'elles sont disposées de manière lisible.

Faire une capture d'écran sous Mac OS

La combinaison de touches CMD + Majuscule + 3 fait une capture de l'ensemble de l'écran. Utilisez plutôt la combinaison CMD + Majuscule + 4. Quand vous la faites au clavier, un curseur en forme de croix apparaît, qui permet de sélectionner la zone de l'écran capturée. Sinon, en appuyant sur la barre d'espace, le curseur prend la forme d'un appareil photo et permet de faire la capture d'une fenêtre entière. Les captures d'écran obtenues apparaissent sur le bureau. Une image peut toujours être recadrée avec l'application Aperçu (Preview) : Sélectionnez la zone à recadrer, et choisissez le menu “Outils” > “Recadrer” (CMD + K).

Faire une capture d'écran sous Windows

L'application “Outil capture” (Menu “Démarrer” > “Tous les programmes” > “Accessoires”) permet de copier l'ensemble de l'écran, une fenêtre isolée, ou une zone précise de l'écran (“Capture rectangulaire”). La touche “Impr. écran” du clavier permet sinon de faire une capture de l'ensemble de l'écran, qui est mise en mémoire et qu'il faut coller dans un autre logiciel pour la récupérer. Une image peut toujours être recadrée avec l'application Paint : Sélectionnez la zone à recadrer, et cliquez sur le bouton “Rogner” (CTRL + Majuscule + X).

Formulaires

Si vous souhaitez faire apparaitre un formulaire dans votre dossier, une capture d'écran pourra aussi être utilisée. Veillez alors à la réaliser en mode lecture et saisie de données.

Les requêtes

Syntaxe d'une requête

Il faut indiquer la syntaxe de chaque requête utilisée dans votre dossier, pas seulement ses résultats. Vous pouvez pour cela faire une capture d'écran des critères utilisés en mode ébauche (1). Il est néanmoins plus rigoureux de recopier la requête en SQL, que vous pouvez faire apparaître en cliquant sur “(Dés)activer le mode Ebauche” (2) ou en faisant un clic-droit sur le nom de la requête dans la fenêtre principale et en choisissant le menu “Editer en mode SQL…”.

Formulation d'une requête avec l'interface graphique :

Formulation de la même requête en SQL :

Pour faciliter la lecture du SQL, vous pouvez souligner sa syntaxe en utilisant le gras, la couleur, etc. Il est aussi recommandé de commenter la logique de votre requête lorsqu'elle n'est pas évidente, d'expliciter les noms de table ou de champ si ils sont abrégés ou obscurs, etc. Pensez d'ailleurs à utiliser les alias pour renommer une colonne de résultats, en particulier lorsqu'il s'agit d'un calcul.

Récupérer les résultats de requêtes

Dans un logiciel de traitement de texte

Plusieurs méthodes permettent de récupérer les résultats d'une requête dans un document fait avec LibreOffice Writer ou Microsoft Word. La plus simple est la suivante :

a) Dans la fenêtre principale de LibreOffice Base, double-cliquez sur le nom de la requête (1) pour faire apparaître ses résultats (attention : la suite ne marche pas si vous partez des résultats affichés dans une fenêtre d'édition de la requête).

b) Sélectionnez tout en cliquant sur la case tout en haut à gauche (2), au niveau des en-têtes des différents champs, et copiez la sélection.

c) Dans LibreOffice Writer ou dans Word, choisissez le menu “Edition” > “Collage spécial…” et l'option “Texte formaté [RTF]” ou “Texte mis en forme (RTF)” (2).

d) Dans Pages (Mac OS), créez un tableau quelconque, cliquez sur sa première case et collez les résultats de votre requête. Le nombre de colonnes et de lignes est automatiquement ajusté.

Copie et mise en forme dans Calc

Faire les points a) et b), et collez la sélection dans un nouveau document Calc.

Le tableau des résultats est ainsi reproduit et peut être mis en forme avec les outils habituels (bordure du tableau, taille des colonnes, mise en forme de la police de caractère, etc.).

Représentation graphique des résultats

En répétant les étapes a) et b) de la partie précédente, vous pouvez recopier les résultats d'une requête dans LibreOffice Calc, Microsof Excel ou Numbers (sur Mac OS), ce qui vous permet de faire des graphiques pour illustrer votre dossier. Le choix du bon type de graphique dépend des données que l'on souhaite représenter. Les exemples ci-dessous (sous LibreOffice Calc) donnent la marche à suivre, avec les requêtes appropriées.

Dans tous les cas...

  • Sélectionnez les séries que vous voulez utiliser dans votre graphique en cliquant sur les différents en-têtes du tableau avec la touche ctrl (sur Windows) ou cmd (sur Mac OS).
  • Veillez à bien mettre en forme votre graphique. Ceci peut se faire lors de sa création ou grâce à des menus contextuels si il est déjà créé. Dans ce cas, double-cliquez dessus (une nouvelle barre d'icônes apparait), puis faites des clics-droit sur les différentes parties du graphique pour en changer l'apparence.
  • Pensez à insérer un titre, à préciser la légende des différents axes
  • Avec un clic-droit sur le graphique, vous pouvez l'exporter comme image, pour l'insérer dans votre dossier.

Comparer les valeurs d'une même variable quantitative chez plusieurs individus

Il peut être intéressant de montrer la distribution d'une variable dans la population étudiée en représentant simplement toutes ses valeurs triées. Dans Base, formulez une requête incluant la variable à représenter, et en appliquant à celle-ci un tri croissant :

Après avoir copié les résultats de cette requête dans Calc, sélectionnez la colonne correspondante, et choisissez le menu “Insertion” > “Objet” > “Diagramme”. Choisissez un diagramme de type “XY (dispersion)”.

La forme de point utilisée par défaut dans Calc n'est pas très lisible. Double-cliquez sur le graphique, puis faites un clic-droit sur un des points et choissisez le menu “Formater les séries de données”. Dans la fenêtre qui apparaît, le menu “Icône” donne accès à d'autres formes de points et il est possible de diminuer les dimensions de ces points.

Montrer une évolution (courbe)

Il faut réserver l'usage des courbes aux séries qui expriment une évolution, en particulier dans le temps. C'est un graphique adapté pour des données obtenues par année. Avec la base AIU, on peut étudier l'évolution du recrutement, en dénombrant les individus regroupés en fonction de l'année de leur première nomination.

Dans Calc, on sélectionne la colonne “Année” et la colonne “Nb de recrutements”, puis on insère un diagramme de type “XY (dispersion) – Ligne seules” (le type “Lignes” ne convient pas car les valeurs seraient espacées de manière régulière, même lorsque il y a plusieurs années d'écart). Il faut préciser que la première colonne contient les étiquettes de la série (qui apparaitront sur l'axe des abscisses).

Pour aller plus loin

Pour les données chronologiques, on peut rajouter une courbe indiquant la moyenne mobile, qui permet de lisser la courbe initiale. LibreOffice et Excel le proposent parmi les options des graphiques (cf. plus bas, “Représenter la corrélation entre deux variables quantitatives”), mais la moyenne pour une année se fait sur les valeurs des années précédentes et la courbe apparait donc décalée.

Pour calculer la moyenne mobile par vous-même :

a) Utilisez la fonction =MOYENNE() en la positionnant bien selon que vous la calculez sur 3, 5, 7 ans, etc. (1)

b) Recopiez-la pour l’ensemble de votre série, jusqu’à ce que la moyenne prenne en compte des cellules vides (2). Pour cela, une fois que vous avez validé la saisie de la formule, il suffit d’attraper le coin inférieur droit de la cellule et de tirer vers le bas.

c) Incluez cette nouvelle colonne dans le graphique en utilisant le menu contextuel « Plage de données ». (3)

d) Ajustez la mise en forme du graphique.

Comparer des sous-populations

Une base de données en SQL, comme celles de LibreOffice Base, permet de calculer des indicateurs pour des individus que l'on regroupe en fonction d'une variable. Il faut pour cela utiliser une requête où l'on applique la fonction “Groupe” à un champ (correspondant à une variable qualitative), et d'autres fonctions, comme la moyenne, à d'autres champs (correspondant à une variable quantitative). Voir l'exemple plus haut dans la partie “Syntaxe d'une requête”.

Dans Calc, sélectionnez l'ensemble du tableau et choisissez le menu “Insertion” > “Objets” > “Diagramme”. Dans la fenêtre qui apparaît, choisissez un diagramme en colonne, le plus adapté pour ce type de données. Dans l'étape “Série de données”, réordonnez ou triez les séries de valeurs que vous voulez représenter.

Calculer des pourcentages

Il peut être pertinent d'indiquer des effectifs non pas en valeur absolue mais en valeur relative. Le calcul de pourcentages peut se faire dans Calc. A la suite des effectifs, calculez le total en tapant : =SOMME(B2:B22) Puis validez avec la touche Entrée. B2 et B22 sont des références à la première et à la dernière cellule du tableau utilisé (colonne B, lignes 2 à 22).

Dans une autre colonne, calculez le pourcentage pour la première ligne en tapant : =B2/B$23*100 (1) Vous pouvez réduire le nombre de chiffres après la virgule avec les boutons “Format numérique” (3), ou afficher le signe “%” en cliquant sur “Format numérique : pourcentage” (2) (dans ce cas, la multiplication par 100 est automatique et il ne faut donc pas l'inclure dans le calcul).

Recopier cette formule en cliquant sur la cellule, puis en tirant le coin inférieur-droit jusqu'en bas de votre tableau. La formule change pour prendre en compte les différentes lignes avec les effectifs ; la cellule contenant le total ne change pas car on a bloqué cette référence avec l'utilisation du “$”. Ces résultats en pourcentages peuvent aussi être utilisés pour faire un graphique.

Représenter la corrélation entre deux variables quantitatives

Construisez un tableau indiquant pour chaque individu deux variables quantitatives. On utilise ici des données sur le cours du blé et la mortalité à l'Hôtel Dieu à Paris. Sélectionnez les colonnes correspondant aux deux variables et créez un nouveau diagramme en choisissant le format “XY (dispersion)”.

Avec ce type de graphique en nuage de points, vous pouvez rajouter une droite de régression, permettant de visualiser et de mesurer la corrélation entre les deux variables. Pour cela, double-cliquez sur le graphique, puis faites un clic-droit sur l’un des points et choisissez le menu « Insérer une courbe de tendance… ». Avec l’onglet “Type”, vous pouvez choisir le modèle mathématique modélisant au mieux cette corrélation et mesurer cette qualité en affichant le coefficient de détermination (R²).

Faire une AFC

Voir le tutoriel dédié à la réalisation d’une AFC à partir d’une base de données.

illustrer_son_dossier_de_base_de_donnees.txt · Dernière modification: 2016/09/29 00:03 par Octave Julien